aboutsummaryrefslogtreecommitdiff
path: root/tests/nix-copy-closure.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/nix-copy-closure.nix')
-rw-r--r--tests/nix-copy-closure.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/nix-copy-closure.nix b/tests/nix-copy-closure.nix
index be0a4a683..0dc147fb3 100644
--- a/tests/nix-copy-closure.nix
+++ b/tests/nix-copy-closure.nix
@@ -29,10 +29,10 @@ makeTest (let pkgA = pkgs.cowsay; pkgB = pkgs.wget; pkgC = pkgs.hello; in {
startAll;
# Create an SSH key on the client.
- my $key = `${pkgs.openssh}/bin/ssh-keygen -t dsa -f key -N ""`;
+ my $key = `${pkgs.openssh}/bin/ssh-keygen -t ed25519 -f key -N ""`;
$client->succeed("mkdir -m 700 /root/.ssh");
- $client->copyFileFromHost("key", "/root/.ssh/id_dsa");
- $client->succeed("chmod 600 /root/.ssh/id_dsa");
+ $client->copyFileFromHost("key", "/root/.ssh/id_ed25519");
+ $client->succeed("chmod 600 /root/.ssh/id_ed25519");
# Install the SSH key on the server.
$server->succeed("mkdir -m 700 /root/.ssh");