aboutsummaryrefslogtreecommitdiff
path: root/tests/nixos/fetchurl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/nixos/fetchurl.nix')
-rw-r--r--tests/nixos/fetchurl.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/nixos/fetchurl.nix b/tests/nixos/fetchurl.nix
index 63c639c31..97365d053 100644
--- a/tests/nixos/fetchurl.nix
+++ b/tests/nixos/fetchurl.nix
@@ -67,6 +67,9 @@ in
out = machine.succeed("curl https://good/index.html")
assert out == "hello world\n"
+ out = machine.succeed("cat ${badCert}/cert.pem > /tmp/cafile.pem; curl --cacert /tmp/cafile.pem https://bad/index.html")
+ assert out == "foobar\n"
+
# Fetching from a server with a trusted cert should work.
machine.succeed("nix build --no-substitute --expr 'import <nix/fetchurl.nix> { url = \"https://good/index.html\"; hash = \"sha256-qUiQTy8PR5uPgZdpSzAYSw0u0cHNKh7A+4XSmaGSpEc=\"; }'")
@@ -74,5 +77,8 @@ in
err = machine.fail("nix build --no-substitute --expr 'import <nix/fetchurl.nix> { url = \"https://bad/index.html\"; hash = \"sha256-rsBwZF/lPuOzdjBZN2E08FjMM3JHyXit0Xi2zN+wAZ8=\"; }' 2>&1")
print(err)
assert "SSL certificate problem: self-signed certificate" in err or "SSL peer certificate or SSH remote key was not OK" in err
+
+ # Fetching from a server with a trusted cert should work via environment variable override.
+ machine.succeed("NIX_SSL_CERT_FILE=/tmp/cafile.pem nix build --no-substitute --expr 'import <nix/fetchurl.nix> { url = \"https://bad/index.html\"; hash = \"sha256-rsBwZF/lPuOzdjBZN2E08FjMM3JHyXit0Xi2zN+wAZ8=\"; }'")
'';
}