aboutsummaryrefslogtreecommitdiff
path: root/tests/nixos/nix-copy-closure.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/nixos/nix-copy-closure.nix')
-rw-r--r--tests/nixos/nix-copy-closure.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/tests/nixos/nix-copy-closure.nix b/tests/nixos/nix-copy-closure.nix
index 66cbfb033..cd25fbbd0 100644
--- a/tests/nixos/nix-copy-closure.nix
+++ b/tests/nixos/nix-copy-closure.nix
@@ -40,6 +40,11 @@ in {
"${pkgs.openssh}/bin/ssh-keygen", "-t", "ed25519", "-f", "key", "-N", ""
], capture_output=True, check=True)
+ server.succeed("systemctl start network-online.target")
+ client.succeed("systemctl start network-online.target")
+ server.wait_for_unit("network-online.target")
+ client.wait_for_unit("network-online.target")
+
client.succeed("mkdir -m 700 /root/.ssh")
client.copy_from_host("key", "/root/.ssh/id_ed25519")
client.succeed("chmod 600 /root/.ssh/id_ed25519")
@@ -47,9 +52,8 @@ in {
# Install the SSH key on the server.
server.succeed("mkdir -m 700 /root/.ssh")
server.copy_from_host("key.pub", "/root/.ssh/authorized_keys")
- server.wait_for_unit("sshd")
- client.wait_for_unit("network.target")
- client.succeed(f"ssh -o StrictHostKeyChecking=no {server.name} 'echo hello world'")
+ server.wait_for_unit("sshd.service")
+ client.succeed(f"ssh -o StrictHostKeyChecking=no {server.name} 'echo hello world' >&2")
# Copy the closure of package A from the client to the server.
server.fail("nix-store --check-validity ${pkgA}")