aboutsummaryrefslogtreecommitdiff
path: root/tests/readfile-context.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/readfile-context.nix')
-rw-r--r--tests/readfile-context.nix19
1 files changed, 14 insertions, 5 deletions
diff --git a/tests/readfile-context.nix b/tests/readfile-context.nix
index 600036a94..54cd1afd9 100644
--- a/tests/readfile-context.nix
+++ b/tests/readfile-context.nix
@@ -6,14 +6,23 @@ let
dependent = mkDerivation {
name = "dependent";
- builder = ./readfile-context.builder.sh;
- input = "${input}/hello";
+ buildCommand = ''
+ mkdir -p $out
+ echo -n "$input1" > "$out/file1"
+ echo -n "$input2" > "$out/file2"
+ '';
+ input1 = "${input}/hello";
+ input2 = "hello";
};
readDependent = mkDerivation {
- name = "read-dependent";
- builder = ./readfile-context.builder.sh;
- input = builtins.readFile dependent;
+ # Will evaluate correctly because file2 doesn't have any references,
+ # even though the `dependent` derivation does.
+ name = builtins.readFile (dependent + "/file2");
+ buildCommand = ''
+ echo "$input" > "$out"
+ '';
+ input = builtins.readFile (dependent + "/file1");
};
in readDependent