aboutsummaryrefslogtreecommitdiff
path: root/tests/remote-builds.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/remote-builds.nix')
-rw-r--r--tests/remote-builds.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/remote-builds.nix b/tests/remote-builds.nix
index b867f13b4..18d490830 100644
--- a/tests/remote-builds.nix
+++ b/tests/remote-builds.nix
@@ -40,7 +40,7 @@ in
builder2 = builder;
client =
- { config, pkgs, ... }:
+ { config, lib, pkgs, ... }:
{ nix.maxJobs = 0; # force remote building
nix.distributedBuilds = true;
nix.buildMachines =
@@ -60,7 +60,7 @@ in
virtualisation.writableStore = true;
virtualisation.pathsInNixDB = [ config.system.build.extraUtils ];
nix.package = nix;
- nix.binaryCaches = [ ];
+ nix.binaryCaches = lib.mkForce [ ];
programs.ssh.extraConfig = "ConnectTimeout 30";
};
};