aboutsummaryrefslogtreecommitdiff
path: root/tests/shell-hello.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/shell-hello.nix')
-rw-r--r--tests/shell-hello.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/shell-hello.nix b/tests/shell-hello.nix
new file mode 100644
index 000000000..77dcbd2a9
--- /dev/null
+++ b/tests/shell-hello.nix
@@ -0,0 +1,17 @@
+with import ./config.nix;
+
+{
+ hello = mkDerivation {
+ name = "hello";
+ buildCommand =
+ ''
+ mkdir -p $out/bin
+ cat > $out/bin/hello <<EOF
+ #! ${shell}
+ who=\$1
+ echo "Hello \''${who:-World} from $out/bin/hello"
+ EOF
+ chmod +x $out/bin/hello
+ '';
+ };
+}