aboutsummaryrefslogtreecommitdiff
path: root/tests/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/shell.nix')
-rw-r--r--tests/shell.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/shell.nix b/tests/shell.nix
index 4912d295a..92d94fbc2 100644
--- a/tests/shell.nix
+++ b/tests/shell.nix
@@ -74,6 +74,10 @@ let pkgs = rec {
'';
bash = shell;
+ bashInteractive = runCommand "bash" {} ''
+ mkdir -p $out/bin
+ ln -s ${shell} $out/bin/bash
+ '';
# ruby "interpreter" that outputs "$@"
ruby = runCommand "ruby" {} ''