aboutsummaryrefslogtreecommitdiff
path: root/tests/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/shell.nix')
-rw-r--r--tests/shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/shell.nix b/tests/shell.nix
index 64817ed5c..4912d295a 100644
--- a/tests/shell.nix
+++ b/tests/shell.nix
@@ -1,4 +1,4 @@
-{ inNixShell ? false, contentAddressed ? false }:
+{ inNixShell ? false, contentAddressed ? false, fooContents ? "foo" }:
let cfg = import ./config.nix; in
with cfg;
@@ -62,7 +62,7 @@ let pkgs = rec {
foo = runCommand "foo" {} ''
mkdir -p $out/bin
- echo 'echo foo' > $out/bin/foo
+ echo 'echo ${fooContents}' > $out/bin/foo
chmod a+rx $out/bin/foo
ln -s ${shell} $out/bin/bash
'';