aboutsummaryrefslogtreecommitdiff
path: root/tests/structured-attrs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/structured-attrs.nix')
-rw-r--r--tests/structured-attrs.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/structured-attrs.nix b/tests/structured-attrs.nix
index 6c77a4391..c39c3a346 100644
--- a/tests/structured-attrs.nix
+++ b/tests/structured-attrs.nix
@@ -16,6 +16,8 @@ mkDerivation {
__structuredAttrs = true;
+ outputs = [ "out" "dev" ];
+
buildCommand = ''
set -x
@@ -30,8 +32,9 @@ mkDerivation {
[[ -v nothing ]]
[[ -z $nothing ]]
- mkdir ''${outputs[out]}
+ mkdir ''${outputs[out]} ''${outputs[dev]}
echo bar > $dest
+ echo foo > $dest2
json=$(cat .attrs.json)
[[ $json =~ '"narHash":"sha256:1r7yc43zqnzl5b0als5vnyp649gk17i37s7mj00xr8kc47rjcybk"' ]]
@@ -57,6 +60,7 @@ mkDerivation {
nothing = null;
dest = "${placeholder "out"}/foo";
+ dest2 = "${placeholder "dev"}/foo";
"foo bar" = "BAD";
"1foobar" = "BAD";