aboutsummaryrefslogtreecommitdiff
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/unit/meson.build')
-rw-r--r--tests/unit/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
index a997a0d56..35a11a5d3 100644
--- a/tests/unit/meson.build
+++ b/tests/unit/meson.build
@@ -212,3 +212,30 @@ test(
protocol : 'gtest',
verbose : true,
)
+
+libcmd_tester = executable(
+ 'liblixcmd-tests',
+ files('libcmd/args.cc'),
+ dependencies : [
+ liblixcmd,
+ liblixutil,
+ liblixmain,
+ liblixexpr,
+ liblixstore,
+ gtest,
+ boost,
+ ],
+)
+
+test(
+ 'libcmd-unit-tests',
+ libcmd_tester,
+ args : tests_args,
+ env : {
+ # No special meaning here, it's just a file laying around that is unlikely to go anywhere
+ # any time soon.
+ '_NIX_TEST_UNIT_DATA': meson.project_source_root() / 'src/nix-env/buildenv.nix',
+ },
+ suite : 'check',
+ protocol : 'gtest',
+)