aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAria <me@aria.rip>2023-10-20 19:04:58 +0100
committerAria <me@aria.rip>2023-10-20 19:04:58 +0100
commitc15ae32ce53d6a59debd6fa03707ff042a5aa498 (patch)
treedcbe1d3180f44b4426f847b6954f732b16819dbe /flake.nix
parent5c318dbaf86747c8b054835f066717c5a30911c5 (diff)
fix nix build
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 9d6c859..64ea3ee 100644
--- a/flake.nix
+++ b/flake.nix
@@ -39,18 +39,18 @@
default = pkgs.stdenvNoCC.mkDerivation rec {
name = "thesis";
src = ./thesis;
- buildInputs = [pkgs.coreutils tex];
+ buildInputs = [pkgs.coreutils tex pkgs.biber];
phases = ["unpackPhase" "buildPhase" "installPhase"];
buildPhase = ''
export PATH="${pkgs.lib.makeBinPath buildInputs}";
mkdir -p .cache/texmf-var
env TEXMFHOME=.cache TEXMFVAR=.cache/texmf-var \
- latexmk -interaction=nonstopmode -pdf -lualatex \
+ latexmk -interaction=nonstopmode -bibtex -pdf \
main.tex
'';
installPhase = ''
mkdir -p $out
- cp document.pdf $out/
+ cp main.pdf $out/
'';
};
};