aboutsummaryrefslogtreecommitdiff
path: root/nix/configuration.nix
diff options
context:
space:
mode:
authorAria Shrimpton <me@aria.rip>2024-01-29 22:48:13 +0000
committerAria Shrimpton <me@aria.rip>2024-01-29 22:48:13 +0000
commitbabd6d51bc3e3b4665cec2b6d0750605c2d6c5bd (patch)
tree2a06caf45d02426e6092409509ed5b90ca1d8648 /nix/configuration.nix
parent8b2556974cb70cddeedc6f4fb1d06d16c1cff5a1 (diff)
nixos configuration
Diffstat (limited to 'nix/configuration.nix')
-rw-r--r--nix/configuration.nix61
1 files changed, 61 insertions, 0 deletions
diff --git a/nix/configuration.nix b/nix/configuration.nix
new file mode 100644
index 0000000..c91059d
--- /dev/null
+++ b/nix/configuration.nix
@@ -0,0 +1,61 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page, on
+# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
+{
+ config,
+ lib,
+ pkgs,
+ modulesPath,
+ candelabra,
+ ...
+}: {
+ imports = [
+ (modulesPath + "/profiles/qemu-guest.nix")
+ ];
+
+ environment.systemPackages = with pkgs; [
+ git
+ just
+ candelabra # :D
+ ];
+
+ nix.settings.experimental-features = ["nix-command" "flakes" "ca-derivations"];
+
+ # Everything below here is just boring machine setup
+ networking.hostName = "candelabra";
+ networking.useDHCP = lib.mkDefault true;
+
+ time.timeZone = "Europe/London";
+ i18n.defaultLocale = "en_US.UTF-8";
+
+ # SSH Access
+ services.openssh = {
+ enable = true;
+ settings.PermitRootLogin = "prohibit-password";
+ };
+
+ users.users.root.openssh.authorizedKeys.keys = [
+ "no-touch-required sk-ssh-ed25519@openssh.com AAAAGnNrLXNzaC1lZDI1NTE5QG9wZW5zc2guY29tAAAAIPpKjZfzPN1KxVskFRnmTTCwzyCtjwcXVZc4i1rNfl9oAAAABHNzaDo= me@aria.rip"
+ ];
+
+ # Boot & filesystems
+ boot.loader.grub.enable = true;
+ boot.loader.grub.device = "/dev/sda";
+
+ boot.initrd.availableKernelModules = ["ata_piix" "uhci_hcd" "virtio_pci" "virtio_scsi" "sd_mod" "sr_mod"];
+ boot.initrd.kernelModules = [];
+ boot.kernelModules = ["kvm-intel"];
+ boot.extraModulePackages = [];
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/b7946a55-0573-4be9-801b-5ca9afc7b3f3";
+ fsType = "ext4";
+ };
+
+ swapDevices = [
+ {device = "/dev/disk/by-uuid/9101d36f-dba8-4dda-8f4b-8dc8c1d37fe9";}
+ ];
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ system.stateVersion = "23.11";
+}