aboutsummaryrefslogtreecommitdiff
path: root/src/Cargo.toml
diff options
context:
space:
mode:
authorAria <me@aria.rip>2023-11-07 22:25:18 +0000
committerAria <me@aria.rip>2023-11-07 22:25:18 +0000
commitc6be430616e97a5bca0ee56f71908589b174a8ff (patch)
tree382857e2b9ac41881d58dad5d33670101f177752 /src/Cargo.toml
parent71236e6332507ef18d14876d200ac83bf895496a (diff)
refactor(all): shorter directory names
Diffstat (limited to 'src/Cargo.toml')
-rw-r--r--src/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/Cargo.toml b/src/Cargo.toml
new file mode 100644
index 0000000..d3658ac
--- /dev/null
+++ b/src/Cargo.toml
@@ -0,0 +1,17 @@
+[workspace]
+resolver = "2"
+members = [
+ "crates/primrose",
+ "crates/library",
+ "crates/cli",
+ "crates/benchmarker"
+]
+
+[workspace.dependencies]
+log = { version = "0.4.20" }
+env_logger = "0.10.0"
+thiserror = "1.0.49"
+anyhow = "1.0.75"
+rand = "0.8.5"
+serde = "1.0.190"
+serde_json = "1.0.108" \ No newline at end of file