aboutsummaryrefslogtreecommitdiff
path: root/src/crates/candelabra/Cargo.toml
diff options
context:
space:
mode:
authorAria <me@aria.rip>2023-12-14 18:42:24 +0000
committerAria <me@aria.rip>2023-12-14 18:42:24 +0000
commit9da1961a33b20cc64d920ae82f6cc49c42d0c728 (patch)
tree6429afb84eaa09e2029fea1e161e64378cf7db74 /src/crates/candelabra/Cargo.toml
parent965e64e8436b24c8523b738ceac84c5a5599d100 (diff)
refactor(candelabra): split cli, reduce duplication
introduce an invalidation function to the cache helper to get rid of repetitive code split cli and candelabra out to separate crates move most top-level operations into the State struct
Diffstat (limited to 'src/crates/candelabra/Cargo.toml')
-rw-r--r--src/crates/candelabra/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/crates/candelabra/Cargo.toml b/src/crates/candelabra/Cargo.toml
new file mode 100644
index 0000000..909e577
--- /dev/null
+++ b/src/crates/candelabra/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "candelabra"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+log = { workspace = true }
+primrose = { path = "../primrose" }
+anyhow = { workspace = true }
+serde = { workspace = true }
+serde_json = { workspace = true }
+camino = "1.1.6"
+cargo_metadata = "0.18.1"
+glob = "0.3.1"
+tempfile = "3"
+nalgebra = "0.32.3"
+polars = { version = "0.35.4", features = ["describe"] }