aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..0de2ba0
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,35 @@
+{
+ description = "A simple command runner";
+
+ outputs = {
+ self,
+ nixpkgs,
+ }: let
+ lastModifiedDate = self.lastModifiedDate or self.lastModified or "19700101";
+ version = builtins.substring 0 8 lastModifiedDate;
+ supportedSystems = ["x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin"];
+ forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
+ nixpkgsFor = forAllSystems (system: import nixpkgs {inherit system;});
+ in {
+ packages = forAllSystems (system: let
+ pkgs = nixpkgsFor.${system};
+ in rec {
+ doe = pkgs.buildGoModule {
+ pname = "doe";
+ inherit version;
+
+ src = ./.;
+ vendorHash = "sha256-CqkoqufGPKWgoi6Dbdl7rcz/jA84xyL7sKbPv5NTDvM=";
+ };
+ default = doe;
+ });
+
+ devShells = forAllSystems (system: let
+ pkgs = nixpkgsFor.${system};
+ in {
+ default = pkgs.mkShell {
+ buildInputs = with pkgs; [go gopls gotools go-tools];
+ };
+ });
+ };
+}