aboutsummaryrefslogtreecommitdiff
path: root/clang-tidy/meson.build
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-03-29 20:26:38 -0700
committerjade <lix@jade.fyi>2024-04-06 04:40:19 +0000
commit43cf487c256395e03f2e10f1f66b3933f201a4e8 (patch)
tree7cd40af4daf8f3c40f50596bbaeb00f5bbe43676 /clang-tidy/meson.build
parent194a1b91af6d8848e4cc0dfbdcc153ee2dbed140 (diff)
Create clang-tidy check to rename all our includes
It is a little bit scuffed, but it seems to produce correct results. We can run it at a later date when we want to explode every in-flight commit in existence and then need to filter-branch them. Fixes: https://git.lix.systems/lix-project/lix/issues/188 Change-Id: Id97e4651f78804a941d941df02c7c1b21ce453b6
Diffstat (limited to 'clang-tidy/meson.build')
-rw-r--r--clang-tidy/meson.build11
1 files changed, 8 insertions, 3 deletions
diff --git a/clang-tidy/meson.build b/clang-tidy/meson.build
index 48770e39f..c59164a72 100644
--- a/clang-tidy/meson.build
+++ b/clang-tidy/meson.build
@@ -1,8 +1,13 @@
-project('nix-clang-tidy', ['cpp', 'c'],
+project('lix-clang-tidy', ['cpp', 'c'],
version : '0.1',
default_options : ['warning_level=3', 'cpp_std=c++20'])
llvm = dependency('Clang', version: '>= 14', modules: ['libclang'])
-sources = ['HasPrefixSuffix.cc', 'NixClangTidyChecks.cc']
-shared_module('nix-clang-tidy', sources,
+sources = files(
+ 'HasPrefixSuffix.cc',
+ 'LixClangTidyChecks.cc',
+ 'FixIncludes.cc',
+)
+
+shared_module('lix-clang-tidy', sources,
dependencies: llvm)