aboutsummaryrefslogtreecommitdiff
path: root/clang-tidy/meson.build
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-03-17 19:54:58 -0700
committerJade Lovelace <lix@jade.fyi>2024-03-18 16:10:29 -0700
commit6b0020749d4b1711b669ba68fe74474f8241f084 (patch)
tree2dc3b3c61350187d299b689571653fd1ca35e131 /clang-tidy/meson.build
parent61e21b25576f7f3491f6a837bf59d8b44c6897a0 (diff)
clang-tidy check infrastructure
This brings in infrastructure for developing new custom clang-tidy lints and refactors for Lix. Change-Id: I3df5f5855712ab4f97d4e84d771e5e818f81f881
Diffstat (limited to 'clang-tidy/meson.build')
-rw-r--r--clang-tidy/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/clang-tidy/meson.build b/clang-tidy/meson.build
new file mode 100644
index 000000000..48770e39f
--- /dev/null
+++ b/clang-tidy/meson.build
@@ -0,0 +1,8 @@
+project('nix-clang-tidy', ['cpp', 'c'],
+ version : '0.1',
+ default_options : ['warning_level=3', 'cpp_std=c++20'])
+
+llvm = dependency('Clang', version: '>= 14', modules: ['libclang'])
+sources = ['HasPrefixSuffix.cc', 'NixClangTidyChecks.cc']
+shared_module('nix-clang-tidy', sources,
+ dependencies: llvm)