aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2010-03-02 16:40:40 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2010-03-02 16:40:40 +0000
commit5414b3b2dbb539a5d1f3cd48c59178ff1bb3aa08 (patch)
tree2e256cd19e30ea310c6c880c944b71d9200b25ca /configure.ac
parent594eaddd1157db8abe2e1c47cdf2180f027559ad (diff)
* Remove the --enable-static-nix flag.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 7 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index 35562882c..4346dde5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,38 +50,24 @@ AC_DEFINE_UNQUOTED(SYSTEM, ["$system"], [platform identifier (`cpu-os')])
test "$localstatedir" = '${prefix}/var' && localstatedir=/nix/var
-# Whether to produce a statically linked binary. On Cygwin, this is
-# the default: dynamically linking against the ATerm DLL does work,
-# except that it requires the ATerm "lib" directory to be in $PATH, as
-# Windows doesn't have anything like an RPATH embedded in executable.
-# Since this is kind of annoying, we use static libraries for now.
-
-AC_ARG_ENABLE(static-nix, AC_HELP_STRING([--enable-static-nix],
- [produce statically linked binaries]),
- static_nix=$enableval, static_nix=no)
-
-if test "$sys_name" = cygwin; then
- static_nix=yes
-fi
-
-if test "$static_nix" = yes; then
+# Windows-specific stuff. On Cygwin, dynamically linking against the
+# ATerm DLL works, except that it requires the ATerm "lib" directory
+# to be in $PATH, as Windows doesn't have anything like an RPATH
+# embedded in executable. Since this is kind of annoying, we use
+# static libraries for now.
+if test "$sys_name" = "cygwin"; then
AC_DISABLE_SHARED
AC_ENABLE_STATIC
fi
-# Windows-specific stuff.
-if test "$sys_name" = "cygwin"; then
- # We cannot delete open files.
- AC_DEFINE(CANNOT_DELETE_OPEN_FILES, 1, [Whether it is impossible to delete open files.])
-fi
-
# Solaris-specific stuff.
if test "$sys_name" = "sunos"; then
# Solaris requires -lsocket -lnsl for network functions
LIBS="-lsocket -lnsl $LIBS"
fi
+
AC_PROG_CC
AC_PROG_CXX
@@ -291,14 +277,6 @@ if test "$(uname)" = "Darwin"; then
fi
-if test "$static_nix" = yes; then
- # `-all-static' has to be added at the end of configure, because
- # the C compiler doesn't know about -all-static (it's filtered out
- # by libtool, but configure doesn't use libtool).
- LDFLAGS="-all-static $LDFLAGS"
-fi
-
-
AM_CONFIG_HEADER([config.h])
AC_CONFIG_FILES([Makefile
externals/Makefile