aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2018-02-18 02:35:01 -0500
committerShea Levy <shea@shealevy.com>2018-02-18 02:35:01 -0500
commit690ac7c90b5bf3c599e210c53365c7d229c8b0ff (patch)
tree67269e9c7ac5cddb69dc8e1ea5e5687405807379 /configure.ac
parent3a5a241b3209f14f8801b902ba20b5cb0666c9df (diff)
configure: Add a flag to disable seccomp.
This is needed for new arches where libseccomp support doesn't exist yet. Fixes #1878.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 83b2346d0..14f742cf3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,9 +186,21 @@ AC_SUBST(HAVE_BROTLI, [$have_brotli])
# Look for libseccomp, required for Linux sandboxing.
if test "$sys_name" = linux; then
- PKG_CHECK_MODULES([LIBSECCOMP], [libseccomp],
- [CXXFLAGS="$LIBSECCOMP_CFLAGS $CXXFLAGS"])
+ AC_ARG_ENABLE([seccomp-sandboxing],
+ AC_HELP_STRING([--disable-seccomp-sandboxing],
+ [Don't build support for seccomp sandboxing (only recommended if your arch doesn't support libseccomp yet!)]
+ ))
+ if test "x$enable_seccomp_sandboxing" != "xno"; then
+ PKG_CHECK_MODULES([LIBSECCOMP], [libseccomp],
+ [CXXFLAGS="$LIBSECCOMP_CFLAGS $CXXFLAGS"])
+ have_seccomp=1
+ else
+ have_seccomp=
+ fi
+else
+ have_seccomp=
fi
+AC_SUBST(HAVE_SECCOMP, [$have_seccomp])
# Look for aws-cpp-sdk-s3.