aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-01-19 08:51:00 -0500
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-01-23 07:05:50 -0500
commit7fe308c2f840325199f49526b257bbe4ded5a909 (patch)
tree5ea58d3ca8724e4d464270a4a46093107cc5a9ab /configure.ac
parent90e630a542c163e4d0fa2fb28bc6e1782e4bd394 (diff)
Add `rapidcheck` dependency for testing
Property tests are great! Co-authored-by: Cole Helbling <cole.e.helbling@outlook.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b0d6fd27..0066bc389 100644
--- a/configure.ac
+++ b/configure.ac
@@ -274,6 +274,12 @@ fi
PKG_CHECK_MODULES([GTEST], [gtest_main])
+# Look for rapidcheck.
+# No pkg-config yet, https://github.com/emil-e/rapidcheck/issues/302
+AC_CHECK_HEADERS([rapidcheck/gtest.h], [], [], [#include <gtest/gtest.h>])
+AC_CHECK_LIB([rapidcheck], [])
+
+
# Look for nlohmann/json.
PKG_CHECK_MODULES([NLOHMANN_JSON], [nlohmann_json >= 3.9])