aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRyan Burns <rtburns@protonmail.com>2021-08-10 00:01:39 -0700
committerRyan Burns <rtburns@protonmail.com>2021-08-10 00:01:39 -0700
commitd86d43c34cf8fcb68cdd67c581380aa21afe3ab6 (patch)
tree44c585633b8965f84f6dadfa0f12464245323fd8 /configure.ac
parent8943e3176d5a94088a2018c3415f2f34fe9309d1 (diff)
Fix host OS detection for darwin-specific linker flag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6e563eec3..494b4831e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -274,9 +274,11 @@ AC_CHECK_FUNCS([strsignal posix_fallocate sysconf])
# This is needed if bzip2 is a static library, and the Nix libraries
# are dynamic.
-if test "$(uname)" = "Darwin"; then
+case "${host_os}" in
+ darwin*)
LDFLAGS="-all_load $LDFLAGS"
-fi
+ ;;
+esac
AC_ARG_WITH(sandbox-shell, AS_HELP_STRING([--with-sandbox-shell=PATH],[path of a statically-linked shell to use as /bin/sh in sandboxes]),