aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFederico Pellegrin <fede@evolware.org>2021-09-14 07:54:37 +0200
committerFederico Pellegrin <fede@evolware.org>2021-09-14 07:54:37 +0200
commite9dbba0fc7ab90e3679ba57245b36420ce76ccc4 (patch)
tree585618abd3412ad5c982fac0fb80dca356197ec9 /configure.ac
parent4ed66735b67b785efad7e23599a1777343c264b5 (diff)
configure: explicit dependency on lowdown library
This dependency is used from quite a long time (now in libcmd) but was not explicitly stated in the configure phase, possibly leading to quite late build failures if that was not met (ie. building it outside the .nix files provided). This MR adds it in the configure phase so the failure is early and error is much more explicit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2841a87c0..65478ecc5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -260,6 +260,8 @@ AC_ARG_ENABLE(doc-gen, AS_HELP_STRING([--disable-doc-gen],[disable documentation
doc_generate=$enableval, doc_generate=yes)
AC_SUBST(doc_generate)
+# Look for lowdown library.
+PKG_CHECK_MODULES([LOWDOWN], [lowdown >= 0.8.0], [CXXFLAGS="$LOWDOWN_CFLAGS $CXXFLAGS"])
# Setuid installations.
AC_CHECK_FUNCS([setresuid setreuid lchown])