aboutsummaryrefslogtreecommitdiff
path: root/corepkgs/imported-drv-to-derivation.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2015-07-23 09:48:03 -0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2015-07-23 17:04:07 +0200
commit39e27a04b8d1fc8251128b1f9f8f152b8c8a9b68 (patch)
tree0f9b47e38fbc40e0595dffe31c41611f709e3f6a /corepkgs/imported-drv-to-derivation.nix
parent1ed55234d9efce7d40c97ef1215090015d18498c (diff)
Importing derivations: Add name attribute to make a valid drv
Diffstat (limited to 'corepkgs/imported-drv-to-derivation.nix')
-rw-r--r--corepkgs/imported-drv-to-derivation.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/corepkgs/imported-drv-to-derivation.nix b/corepkgs/imported-drv-to-derivation.nix
index bdb601698..eab8b050e 100644
--- a/corepkgs/imported-drv-to-derivation.nix
+++ b/corepkgs/imported-drv-to-derivation.nix
@@ -1,10 +1,10 @@
-attrs @ { drvPath, outputs, ... }:
+attrs @ { drvPath, outputs, name, ... }:
let
commonAttrs = (builtins.listToAttrs outputsList) //
{ all = map (x: x.value) outputsList;
- inherit drvPath;
+ inherit drvPath name;
type = "derivation";
};