aboutsummaryrefslogtreecommitdiff
path: root/doc/manual/generate-manpage.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2020-12-02 23:05:28 +0100
committerEelco Dolstra <edolstra@gmail.com>2020-12-02 23:23:23 +0100
commit72428e38d904a1db746f37c8727ab7b0fbb457bc (patch)
treed70f6a2849265432270b8495de899def6df271ea /doc/manual/generate-manpage.nix
parentdf552a26452f4cdf734edcac049187b8fd806153 (diff)
Generate separate manpages for each nix subcommand
Diffstat (limited to 'doc/manual/generate-manpage.nix')
-rw-r--r--doc/manual/generate-manpage.nix50
1 files changed, 34 insertions, 16 deletions
diff --git a/doc/manual/generate-manpage.nix b/doc/manual/generate-manpage.nix
index db266750a..2801e96fa 100644
--- a/doc/manual/generate-manpage.nix
+++ b/doc/manual/generate-manpage.nix
@@ -1,34 +1,40 @@
+command:
+
with builtins;
with import ./utils.nix;
let
showCommand =
- { command, section, def }:
- "${section} Name\n\n"
+ { command, def, filename }:
+ "# Name\n\n"
+ "`${command}` - ${def.description}\n\n"
- + "${section} Synopsis\n\n"
+ + "# Synopsis\n\n"
+ showSynopsis { inherit command; args = def.args; }
+ + (if def.commands or {} != {}
+ then
+ "where *subcommand* is one of the following:\n\n"
+ # FIXME: group by category
+ + concatStrings (map (name:
+ "* [`${command} ${name}`](./${appendName filename name}.md) - ${def.commands.${name}.description}\n")
+ (attrNames def.commands))
+ + "\n"
+ else "")
+ (if def ? doc
- then "${section} Description\n\n" + def.doc + "\n\n"
+ then "# Description\n\n" + def.doc + "\n\n"
else "")
+ (let s = showFlags def.flags; in
if s != ""
- then "${section} Flags\n\n${s}"
+ then "# Flags\n\n${s}"
else "")
+ (if def.examples or [] != []
then
- "${section} Examples\n\n"
+ "# Examples\n\n"
+ concatStrings (map ({ description, command }: "${description}\n\n```console\n${command}\n```\n\n") def.examples)
- else "")
- + (if def.commands or [] != []
- then concatStrings (
- map (name:
- "# Subcommand `${command} ${name}`\n\n"
- + showCommand { command = command + " " + name; section = "##"; def = def.commands.${name}; })
- (attrNames def.commands))
else "");
+ appendName = filename: name: (if filename == "nix" then "nix3" else filename) + "-" + name;
+
showFlags = flags:
concatStrings
(map (longName:
@@ -48,8 +54,20 @@ let
"`${command}` [*flags*...] ${concatStringsSep " "
(map (arg: "*${arg.label}*" + (if arg ? arity then "" else "...")) args)}\n\n";
-in
+ processCommand = { command, def, filename }:
+ [ { name = filename + ".md"; value = showCommand { inherit command def filename; }; inherit command; } ]
+ ++ concatMap
+ (name: processCommand {
+ filename = appendName filename name;
+ command = command + " " + name;
+ def = def.commands.${name};
+ })
+ (attrNames def.commands or {});
-command:
+in
-showCommand { command = "nix"; section = "#"; def = command; }
+let
+ manpages = processCommand { filename = "nix"; command = "nix"; def = command; };
+ summary = concatStrings (map (manpage: " - [${manpage.command}](command-ref/new-cli/${manpage.name})\n") manpages);
+in
+(listToAttrs manpages) // { "SUMMARY.md" = summary; }