aboutsummaryrefslogtreecommitdiff
path: root/doc/manual/generate-manpage.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2021-02-25 20:35:11 +0000
committerJohn Ericson <John.Ericson@Obsidian.Systems>2021-02-25 21:51:05 +0000
commitca0994819d68aee26a2906c37a47ae609ac46c4c (patch)
treec96805c008c22926b1eaadc340a99323d53be532 /doc/manual/generate-manpage.nix
parent10e81bf871551901ff0383bdede0f79325e93867 (diff)
parentc189031e8be0530d73a817571ad7f81ad5eedce6 (diff)
Merge remote-tracking branch 'upstream/master' into path-info
Diffstat (limited to 'doc/manual/generate-manpage.nix')
-rw-r--r--doc/manual/generate-manpage.nix112
1 files changed, 76 insertions, 36 deletions
diff --git a/doc/manual/generate-manpage.nix b/doc/manual/generate-manpage.nix
index db266750a..964b57086 100644
--- a/doc/manual/generate-manpage.nix
+++ b/doc/manual/generate-manpage.nix
@@ -1,55 +1,95 @@
+command:
+
with builtins;
with import ./utils.nix;
let
showCommand =
- { command, section, def }:
- "${section} Name\n\n"
+ { command, def, filename }:
+ ''
+ **Warning**: This program is **experimental** and its interface is subject to change.
+ ''
+ + "# Name\n\n"
+ "`${command}` - ${def.description}\n\n"
- + "${section} Synopsis\n\n"
+ + "# Synopsis\n\n"
+ showSynopsis { inherit command; args = def.args; }
+ + (if def.commands or {} != {}
+ then
+ let
+ categories = sort (x: y: x.id < y.id) (unique (map (cmd: cmd.category) (attrValues def.commands)));
+ listCommands = cmds:
+ concatStrings (map (name:
+ "* [`${command} ${name}`](./${appendName filename name}.md) - ${cmds.${name}.description}\n")
+ (attrNames cmds));
+ in
+ "where *subcommand* is one of the following:\n\n"
+ # FIXME: group by category
+ + (if length categories > 1
+ then
+ concatStrings (map
+ (cat:
+ "**${toString cat.description}:**\n\n"
+ + listCommands (filterAttrs (n: v: v.category == cat) def.commands)
+ + "\n"
+ ) categories)
+ + "\n"
+ else
+ listCommands def.commands
+ + "\n")
+ else "")
+ (if def ? doc
- then "${section} Description\n\n" + def.doc + "\n\n"
+ then def.doc + "\n\n"
else "")
- + (let s = showFlags def.flags; in
+ + (let s = showOptions def.flags; in
if s != ""
- then "${section} Flags\n\n${s}"
+ then "# Options\n\n${s}"
else "")
- + (if def.examples or [] != []
- then
- "${section} Examples\n\n"
- + concatStrings (map ({ description, command }: "${description}\n\n```console\n${command}\n```\n\n") def.examples)
- else "")
- + (if def.commands or [] != []
- then concatStrings (
- map (name:
- "# Subcommand `${command} ${name}`\n\n"
- + showCommand { command = command + " " + name; section = "##"; def = def.commands.${name}; })
- (attrNames def.commands))
- else "");
-
- showFlags = flags:
- concatStrings
- (map (longName:
- let flag = flags.${longName}; in
- if flag.category or "" != "config"
- then
- " - `--${longName}`"
- + (if flag ? shortName then " / `${flag.shortName}`" else "")
- + (if flag ? labels then " " + (concatStringsSep " " (map (s: "*${s}*") flag.labels)) else "")
- + " \n"
- + " " + flag.description + "\n\n"
- else "")
- (attrNames flags));
+ ;
+
+ appendName = filename: name: (if filename == "nix" then "nix3" else filename) + "-" + name;
+
+ showOptions = flags:
+ let
+ categories = sort builtins.lessThan (unique (map (cmd: cmd.category) (attrValues flags)));
+ in
+ concatStrings (map
+ (cat:
+ (if cat != ""
+ then "**${cat}:**\n\n"
+ else "")
+ + concatStrings
+ (map (longName:
+ let
+ flag = flags.${longName};
+ in
+ " - `--${longName}`"
+ + (if flag ? shortName then " / `-${flag.shortName}`" else "")
+ + (if flag ? labels then " " + (concatStringsSep " " (map (s: "*${s}*") flag.labels)) else "")
+ + " \n"
+ + " " + flag.description + "\n\n"
+ ) (attrNames (filterAttrs (n: v: v.category == cat) flags))))
+ categories);
showSynopsis =
{ command, args }:
- "`${command}` [*flags*...] ${concatStringsSep " "
+ "`${command}` [*option*...] ${concatStringsSep " "
(map (arg: "*${arg.label}*" + (if arg ? arity then "" else "...")) args)}\n\n";
-in
+ processCommand = { command, def, filename }:
+ [ { name = filename + ".md"; value = showCommand { inherit command def filename; }; inherit command; } ]
+ ++ concatMap
+ (name: processCommand {
+ filename = appendName filename name;
+ command = command + " " + name;
+ def = def.commands.${name};
+ })
+ (attrNames def.commands or {});
-command:
+in
-showCommand { command = "nix"; section = "#"; def = command; }
+let
+ manpages = processCommand { filename = "nix"; command = "nix"; def = command; };
+ summary = concatStrings (map (manpage: " - [${manpage.command}](command-ref/new-cli/${manpage.name})\n") manpages);
+in
+(listToAttrs manpages) // { "SUMMARY.md" = summary; }