aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 13:53:13 -0500
committerGitHub <noreply@github.com>2023-12-01 13:53:13 -0500
commit211b6e18556e03829ae7bba38c7272af2900a2e8 (patch)
treebfcfef3efeb73cb0c3c6d812280191d03bda1233 /flake.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
parentf7f37035c81fa825a4dfc2df1ad2589013ac6380 (diff)
Merge pull request #9517 from NixOS/2.18-flatten-tests
[Backport 2.18-maintanence] Backport test source layout reorgs
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix53
1 files changed, 23 insertions, 30 deletions
diff --git a/flake.nix b/flake.nix
index 1d629bb6a..230bb6031 100644
--- a/flake.nix
+++ b/flake.nix
@@ -24,7 +24,7 @@
linuxSystems = linux32BitSystems ++ linux64BitSystems;
darwinSystems = [ "x86_64-darwin" "aarch64-darwin" ];
systems = linuxSystems ++ darwinSystems;
-
+
crossSystems = [ "armv6l-linux" "armv7l-linux" ];
stdenvs = [ "gccStdenv" "clangStdenv" "clang11Stdenv" "stdenv" "libcxxStdenv" "ccacheStdenv" ];
@@ -58,35 +58,28 @@
nixSrc = fileset.toSource {
root = ./.;
- fileset = fileset.intersect baseFiles (
- fileset.difference
- (fileset.unions [
- ./.version
- ./boehmgc-coroutine-sp-fallback.diff
- ./bootstrap.sh
- ./configure.ac
- ./doc
- ./local.mk
- ./m4
- ./Makefile
- ./Makefile.config.in
- ./misc
- ./mk
- ./precompiled-headers.h
- ./src
- ./tests
- ./COPYING
- ./scripts/local.mk
- (fileset.fileFilter (f: lib.strings.hasPrefix "nix-profile" f.name) ./scripts)
- # TODO: do we really need README.md? It doesn't seem used in the build.
- ./README.md
- ])
- (fileset.unions [
- # Removed file sets
- ./tests/nixos
- ./tests/installer
- ])
- );
+ fileset = fileset.intersect baseFiles (fileset.unions [
+ ./.version
+ ./boehmgc-coroutine-sp-fallback.diff
+ ./bootstrap.sh
+ ./configure.ac
+ ./doc
+ ./local.mk
+ ./m4
+ ./Makefile
+ ./Makefile.config.in
+ ./misc
+ ./mk
+ ./precompiled-headers.h
+ ./src
+ ./tests/functional
+ ./tests/unit
+ ./COPYING
+ ./scripts/local.mk
+ (fileset.fileFilter (f: lib.strings.hasPrefix "nix-profile" f.name) ./scripts)
+ # TODO: do we really need README.md? It doesn't seem used in the build.
+ ./README.md
+ ]);
};
# Memoize nixpkgs for different platforms for efficiency.