diff options
author | eldritch horrors <pennae@lix.systems> | 2024-03-26 18:32:25 +0100 |
---|---|---|
committer | eldritch horrors <pennae@lix.systems> | 2024-03-27 03:09:14 +0000 |
commit | 279e30e7ef4cae96d1f5fcbc5fc02ebb4779199b (patch) | |
tree | 045935b89a5067c297cb50e7a28ca3a81cf411fc /flake.nix | |
parent | 8fd02df90d2a8099d2d547e151b876f77fb5a4a2 (diff) |
build: replace changelog-d with local script
hacking changelog-d to support not just github but also forgejo and
gerrit is a lot more complicated than it's worth, even moreso since
the entire thing can just as well be done with ~60 lines of python.
this new script is also much cheaper to instantiate (being python),
so having it enabled in all shells is far less of a hassle.
we've also adjusted existing release notes that referenced a gerrit
cl to auto-link to the cl in question, making the diff a bit bigger
closes https://git.lix.systems/lix-project/lix/issues/176
Change-Id: I8ba7dd0070aad9ba4474401731215fcf5d9d2130
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -150,7 +150,8 @@ # Forward from the previous stage as we don’t want it to pick the lowdown override nixUnstable = prev.nixUnstable; - changelog-d = final.buildPackages.callPackage ./misc/changelog-d.nix { }; + build-release-notes = + final.buildPackages.callPackage ./maintainers/build-release-notes.nix { }; boehmgc-nix = (final.boehmgc.override { enableLargeConfig = true; }).overrideAttrs (o: { @@ -238,7 +239,7 @@ nix = pkgs.callPackage ./package.nix { inherit versionSuffix fileset officialRelease buildUnreleasedNotes; - inherit (pkgs) changelog-d; + inherit (pkgs) build-release-notes; internalApiDocs = true; boehmgc = pkgs.boehmgc-nix; busybox-sandbox-shell = pkgs.busybox-sandbox-shell; @@ -288,7 +289,7 @@ rl-next = let pkgs = nixpkgsFor.${system}.native; in pkgs.buildPackages.runCommand "test-rl-next-release-notes" { } '' - LANG=C.UTF-8 ${pkgs.changelog-d}/bin/changelog-d ${./doc/manual/rl-next} >$out + LANG=C.UTF-8 ${lib.getExe pkgs.build-release-notes} ${./doc/manual/rl-next} >$out ''; } // (lib.optionalAttrs (builtins.elem system linux64BitSystems)) { dockerImage = self.hydraJobs.dockerImage.${system}; |