diff options
author | jade <lix@jade.fyi> | 2024-06-07 03:53:31 +0000 |
---|---|---|
committer | Gerrit Code Review <gerrit@lix-systems> | 2024-06-07 03:53:31 +0000 |
commit | 4f94531209510c7d580e525a017ea01f18894ded (patch) | |
tree | c5b8e06f73a5fd27ed6afa53a22b9fca145c4638 /flake.nix | |
parent | ec768df0046659e75974919f5923661a29ff52c9 (diff) | |
parent | 611b1de441a54d3ed7781ca0a26b51b6cb9c45cc (diff) |
Merge changes from topic "releng" into main
* changes:
Add meson release note
Move version to a JSON file so we can have release names
Remove rl-next-dev
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 10 |
1 files changed, 3 insertions, 7 deletions
@@ -59,7 +59,6 @@ # Set to true to build the release notes for the next release. buildUnreleasedNotes = true; - version = lib.fileContents ./.version + versionSuffix; versionSuffix = if officialRelease then "" @@ -149,8 +148,7 @@ } ); - binaryTarball = - nix: pkgs: pkgs.callPackage ./nix-support/binary-tarball.nix { inherit nix version; }; + binaryTarball = nix: pkgs: pkgs.callPackage ./nix-support/binary-tarball.nix { inherit nix; }; overlayFor = getStdenv: final: prev: @@ -227,7 +225,6 @@ in { user = rl-next-check "rl-next" ./doc/manual/rl-next; - dev = rl-next-check "rl-next-dev" ./doc/manual/rl-next-dev; } ); @@ -309,7 +306,6 @@ perlBindings = self.hydraJobs.perlBindings.${system}; nixpkgsLibTests = self.hydraJobs.tests.nixpkgsLibTests.${system}; rl-next = self.hydraJobs.rl-next.${system}.user; - rl-next-dev = self.hydraJobs.rl-next.${system}.dev; # Will be empty attr set on i686-linux, and filtered out by forAvailableSystems. pre-commit = self.hydraJobs.pre-commit.${system}; } @@ -332,10 +328,10 @@ pkgs = nixpkgsFor.${system}.native; image = import ./docker.nix { inherit pkgs; - tag = version; + tag = pkgs.nix.version; }; in - pkgs.runCommand "docker-image-tarball-${version}" + pkgs.runCommand "docker-image-tarball-${pkgs.nix.version}" { meta.description = "Docker image with Lix for ${system}"; } '' mkdir -p $out/nix-support |