aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorRobert Hensing <robert@roberthensing.nl>2023-01-18 00:17:59 +0100
committerRobert Hensing <robert@roberthensing.nl>2023-01-18 01:55:21 +0100
commit620e4fb89bd08fb35e83d18d84f5f635a83239d8 (patch)
tree2910737cd94bd030f8a3bcc7760b190fd99c9c90 /flake.nix
parent9b33ef3879a764bed4cc2404a08344c3a697a646 (diff)
flake.nix: Add nixpkgs/lib/tests as regression test
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 68011a16b..573373c42 100644
--- a/flake.nix
+++ b/flake.nix
@@ -532,6 +532,12 @@
mkdir $out
'';
+ tests.nixpkgsLibTests =
+ nixpkgs.lib.genAttrs systems (system:
+ import (nixpkgs + "/lib/tests/release.nix")
+ { pkgs = nixpkgsFor.${system}; }
+ );
+
metrics.nixpkgs = import "${nixpkgs-regression}/pkgs/top-level/metrics.nix" {
pkgs = nixpkgsFor.x86_64-linux;
nixpkgs = nixpkgs-regression;
@@ -562,6 +568,7 @@
binaryTarball = self.hydraJobs.binaryTarball.${system};
perlBindings = self.hydraJobs.perlBindings.${system};
installTests = self.hydraJobs.installTests.${system};
+ nixpkgsLibTests = self.hydraJobs.tests.nixpkgsLibTests.${system};
} // (nixpkgs.lib.optionalAttrs (builtins.elem system linux64BitSystems)) {
dockerImage = self.hydraJobs.dockerImage.${system};
});