diff options
author | p01arst0rm <polar@ever3st.com> | 2023-08-23 19:28:24 +0100 |
---|---|---|
committer | p01arst0rm <polar@ever3st.com> | 2023-08-23 19:28:24 +0100 |
commit | 7d82341633d81f50f3e5e0b0896cfac5ea805d57 (patch) | |
tree | f7a61c549beaf90784d1891ce2b868a058a2d25c /flake.nix | |
parent | 4a435ad2288bffd5c28d90758e4e26160b53fb8c (diff) |
update system definitions
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 8 |
1 files changed, 5 insertions, 3 deletions
@@ -19,10 +19,12 @@ then "" else "pre${builtins.substring 0 8 (self.lastModifiedDate or self.lastModified or "19700101")}_${self.shortRev or "dirty"}"; + linux32BitSystems = [ "i686-linux" ]; linux64BitSystems = [ "x86_64-linux" "aarch64-linux" ]; - linuxSystems = linux64BitSystems ++ [ "i686-linux" ]; - systems = linuxSystems ++ [ "x86_64-darwin" "aarch64-darwin" ]; - + linuxSystems = linux32BitSystems ++ linux64BitSystems; + darwinSystems = [ "x86_64-darwin" "aarch64-darwin" ]; + systems = linuxSystems ++ darwinSystems; + crossSystems = [ "armv6l-linux" "armv7l-linux" ]; stdenvs = [ "gccStdenv" "clangStdenv" "clang11Stdenv" "stdenv" "libcxxStdenv" "ccacheStdenv" ]; |