aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorregnat <rg@regnat.ovh>2021-09-20 14:37:09 +0200
committerregnat <rg@regnat.ovh>2021-09-20 14:37:09 +0200
commit81ed6ee20199e99d3f22bfcbd49eafc678608fc0 (patch)
tree4301667cb21a8a65bcb3c5808284432d1193ffb8 /flake.nix
parent2933d3c588a256430064fe98abb393e79452f6c2 (diff)
flake: Use the real nixUnstable from nixpkgs
Don’t let it pick our overriden lowdown as that would cause it not to be cached in cache.nixos.org
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 9b737b850..5f77e42d1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -259,11 +259,11 @@
# 'nix.perl-bindings' packages.
overlay = final: prev: {
- # An older version of Nix to test against when using the daemon.
- # Currently using `nixUnstable` as the stable one doesn't respect
- # `NIX_DAEMON_SOCKET_PATH` which is needed for the tests.
nixStable = prev.nix;
+ # Forward from the previous stage as we don’t want it to pick the lowdown override
+ nixUnstable = prev.nixUnstable;
+
nix = with final; with commonDeps pkgs; stdenv.mkDerivation {
name = "nix-${version}";
inherit version;