aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-06-07 01:35:26 -0700
committerJade Lovelace <lix@jade.fyi>2024-06-09 20:33:24 -0700
commit9bb7fb8f698d6ef4d42d068a576abd98d36f8239 (patch)
tree7912d62732f96c4906635f45faaf6f96ea04a306 /flake.nix
parentff95b980d4913e90bc334227f8f3f7b3daf18b36 (diff)
Rewrite docker to be sensible and smaller
I have checked the image can build things and inspected `diff -ru` compared to the old image. As far as I can tell it is more or less the same besides the later git change. Layers are now 65MB or less, and we aren't against the maxLayers limit for the broken automatic layering to do anything but shove one store path in a layer (which is good behaviour, actually). This uses nix2container which streams images, so the build time is much shorter. I have also taken the opportunity to, in addition to fixing the 400MB single layer (terrible, and what motivated this in the first place), delete about 200MB of closure size inflicted by git vs gitMinimal causing both perl and python to get into closure. People mostly use this thing for CI, so I don't really think you need advanced git operations, and large git can be added at the user side if really motivated. With love for whichever container developer somewhat ironically assumed that one would not run skopeo in a minimal container that doesn't have a /var/tmp. Fixes: https://git.lix.systems/lix-project/lix/issues/378 Change-Id: Icc3aa20e64446276716fbbb87535fd5b50628010
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix23
1 files changed, 11 insertions, 12 deletions
diff --git a/flake.nix b/flake.nix
index 8460201b0..6c7abaeec 100644
--- a/flake.nix
+++ b/flake.nix
@@ -8,6 +8,10 @@
url = "github:cachix/git-hooks.nix";
flake = false;
};
+ nix2container = {
+ url = "github:nlewo/nix2container";
+ flake = false;
+ };
flake-compat = {
url = "github:edolstra/flake-compat";
flake = false;
@@ -20,6 +24,7 @@
nixpkgs,
nixpkgs-regression,
pre-commit-hooks,
+ nix2container,
flake-compat,
}:
@@ -330,19 +335,13 @@
dockerImage =
let
pkgs = nixpkgsFor.${system}.native;
- image = import ./docker.nix {
- inherit pkgs;
- tag = pkgs.nix.version;
- };
+ nix2container' = import nix2container { inherit pkgs system; };
in
- pkgs.runCommand "docker-image-tarball-${pkgs.nix.version}"
- { meta.description = "Docker image with Lix for ${system}"; }
- ''
- mkdir -p $out/nix-support
- image=$out/image.tar.gz
- ln -s ${image} $image
- echo "file binary-dist $image" >> $out/nix-support/hydra-build-products
- '';
+ import ./docker.nix {
+ inherit pkgs;
+ nix2container = nix2container'.nix2container;
+ tag = pkgs.nix.version;
+ };
}
// builtins.listToAttrs (
map (crossSystem: {