aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-03-08 21:09:11 -0700
committerQyriad <qyriad@qyriad.me>2024-03-11 04:26:35 -0600
commitb072c069b741d5939baf0350d53392197da3b2d7 (patch)
tree744ceb3324177b2398e8afb484341ebc9f9f2109 /flake.nix
parent4ad3446311de5fc7a1f254dcda7634126d87435c (diff)
package: migrate internal-api-docs
Change-Id: I344d73a412c2c6e4bb2eb14bd4859056324f1ba7
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix43
1 files changed, 19 insertions, 24 deletions
diff --git a/flake.nix b/flake.nix
index e547846f8..f991e4d46 100644
--- a/flake.nix
+++ b/flake.nix
@@ -421,31 +421,26 @@
dockerImage = lib.genAttrs linux64BitSystems (system: self.packages.${system}.dockerImage);
# API docs for Nix's unstable internal C++ interfaces.
- internal-api-docs =
- with nixpkgsFor.x86_64-linux.native;
- with commonDeps { inherit pkgs; };
-
- stdenv.mkDerivation {
- pname = "nix-internal-api-docs";
- inherit version;
-
- src = nixSrc;
-
- configureFlags = testConfigureFlags ++ internalApiDocsConfigureFlags;
-
- nativeBuildInputs = nativeBuildDeps;
- buildInputs = buildDeps ++ propagatedDeps
- ++ awsDeps ++ checkDeps ++ internalApiDocsDeps;
-
- dontBuild = true;
-
- installTargets = [ "internal-api-html" ];
-
- postInstall = ''
- mkdir -p $out/nix-support
- echo "doc internal-api-docs $out/share/doc/nix/internal-api/html" >> $out/nix-support/hydra-build-products
- '';
+ internal-api-docs = let
+ nixpkgs = nixpkgsFor.x86_64-linux.native;
+ inherit (nixpkgs) pkgs;
+ comDeps = commonDeps { inherit pkgs; };
+
+ nix = nixpkgs.pkgs.callPackage ./package.nix {
+ inherit versionSuffix fileset officialRelease buildUnreleasedNotes;
+ inherit (comDeps) changelog-d;
+ internalApiDocs = true;
+ boehmgc = comDeps.boehmgc-nix;
+ busybox-sandbox-shell = comDeps.sh;
};
+ in
+ nix.overrideAttrs (prev: {
+ # This Hydra job is just for the internal API docs.
+ # We don't need the build artifacts here.
+ dontBuild = true;
+ doCheck = false;
+ doInstallCheck = false;
+ });
# System tests.
tests = import ./tests/nixos { inherit lib nixpkgs nixpkgsFor; } // {