aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorRobert Hensing <robert@roberthensing.nl>2024-05-27 09:58:49 +0200
committerJörg Thalheim <joerg@thalheim.io>2024-06-16 04:03:32 +0000
commitb588a761febc62bd6f3a224c0eb8d181b44dbe3c (patch)
tree35587635ff0a5795200a6bd70c2313d4f7763cb8 /flake.nix
parent4734ce7831daf6e7e976029017b1cc2e7e615f30 (diff)
Merge pull request #10799 from hercules-ci/safer-tab-completion
Add repl completion test (cherry picked from commit 1e2b26734b4da101247678aec405c9dcfdc33f98) Change-Id: Ic3de39e71960a05a8676190b1ec9a7f0bb6057f5 Signed-off-by: Jörg Thalheim <joerg@thalheim.io>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 792387da4..372983f6d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -233,6 +233,11 @@
}
);
+ # Completion tests for the Nix REPL.
+ repl-completion = forAllSystems (
+ system: nixpkgsFor.${system}.native.callPackage ./tests/repl-completion.nix { }
+ );
+
# Perl bindings for various platforms.
perlBindings = forAllSystems (system: nixpkgsFor.${system}.native.nix.passthru.perl-bindings);
@@ -330,6 +335,7 @@
rl-next = self.hydraJobs.rl-next.${system}.user;
# Will be empty attr set on i686-linux, and filtered out by forAvailableSystems.
pre-commit = self.hydraJobs.pre-commit.${system};
+ repl-completion = self.hydraJobs.repl-completion.${system};
}
// (lib.optionalAttrs (builtins.elem system linux64BitSystems)) {
dockerImage = self.hydraJobs.dockerImage.${system};