aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-09-01 01:37:10 +0200
committereldritch horrors <pennae@lix.systems>2024-09-09 01:48:20 +0000
commitc14486ae8d3bbc862c625d948a6b2f4dc0927d5b (patch)
treec2b2d1256d6e8cdb292537f3f339fec5907fb86f /flake.nix
parente9505dcc5a0ff259b9e284e9e617486e81a1ff6f (diff)
forbid gcc for compilation, only allow clang
while gcc 12 and older miscompile our generators, gcc 13 and older outright crash on kj coroutines. (newer gcc versions may fix this) Change-Id: I19f12c8c147239680eb0fa5a84ef5c7de38c9263
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 662469479..46f9e43e8 100644
--- a/flake.nix
+++ b/flake.nix
@@ -99,9 +99,10 @@
];
stdenvs = [
- "gccStdenv"
+ # see assertion in package.nix why these two are disabled
+ # "stdenv"
+ # "gccStdenv"
"clangStdenv"
- "stdenv"
"libcxxStdenv"
"ccacheStdenv"
];
@@ -121,7 +122,11 @@
name = "${stdenvName}Packages";
value = f stdenvName;
}) stdenvs
- );
+ )
+ // {
+ # TODO delete this and reënable gcc stdenvs once gcc compiles kj coros correctly
+ stdenvPackages = f "clangStdenv";
+ };
# Memoize nixpkgs for different platforms for efficiency.
nixpkgsFor = forAllSystems (