aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-05-31 16:35:13 -0700
committerJade Lovelace <lix@jade.fyi>2024-06-06 20:53:08 -0700
commitc32a01f9ebae026c1b7b8ba081411581453b4624 (patch)
treec246e14bc178bfa1ea2ad6fe6487d80b528a31dc /flake.nix
parent611b1de441a54d3ed7781ca0a26b51b6cb9c45cc (diff)
Put into place initial release engineering
This can release x86_64-linux binaries to staging, with ephemeral keys. I think it's good enough to review at least at this point, so we don't keep adding more stuff to it to make it harder to review. Change-Id: Ie95e8f35d1252f5d014e819566f170b30eda152e
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index fd8b7995e..a61699b69 100644
--- a/flake.nix
+++ b/flake.nix
@@ -207,7 +207,6 @@
overlays.default = overlayFor (p: p.stdenv);
hydraJobs = {
-
# Binary package for various platforms.
build = forAllSystems (system: self.packages.${system}.nix);
@@ -297,6 +296,11 @@
);
};
+ release-jobs = import ./releng/release-jobs.nix {
+ inherit (self) hydraJobs;
+ pkgs = nixpkgsFor.x86_64-linux.native;
+ };
+
# NOTE *do not* add fresh derivations to checks, always add them to
# hydraJobs first (so CI will pick them up) and only link them here
checks = forAvailableSystems (