aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-04-07 15:51:12 -0700
committerJade Lovelace <lix@jade.fyi>2024-04-07 17:30:22 -0700
commitde20392c37c79f0aea03d4f580171178d896be15 (patch)
tree59b51ff75909b9249463162a8c2366cbf87a61fb /flake.nix
parent84599abd4c25e4991e0bc53c87a03ad6bfc97e2f (diff)
flake: remove dead code
Some of this code existed for installer tests, and indeed its removal is an indication that our daemon cross-compatibility tests were removed. Although these are not like, super critical tests, we would like to restore them. See: https://git.lix.systems/lix-project/lix/issues/33 Change-Id: I75c733b25c00eca3a9676d498703bbfc1d6ec21b
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/flake.nix b/flake.nix
index 76b397b29..74d321c61 100644
--- a/flake.nix
+++ b/flake.nix
@@ -83,39 +83,6 @@
cross = forAllCrossSystems (crossSystem: make-pkgs crossSystem "stdenv");
});
- testNixVersions = pkgs: client: daemon: let
- nix = pkgs.callPackage ./package.nix {
- pname =
- "nix-tests"
- + lib.optionalString
- (lib.versionAtLeast daemon.version "2.4pre20211005" &&
- lib.versionAtLeast client.version "2.4pre20211005")
- "-${client.version}-against-${daemon.version}";
- };
- in nix.overrideAttrs (prevAttrs: {
- NIX_DAEMON_PACKAGE = daemon;
- NIX_CLIENT_PACKAGE = client;
-
- dontBuild = true;
- doInstallCheck = true;
-
- configureFlags = prevAttrs.configureFlags ++ [
- # We don't need the actual build here.
- "--disable-build"
- ];
-
- installPhase = ''
- mkdir -p $out
- '';
-
- installCheckPhase = lib.optionalString pkgs.stdenv.hostPlatform.isDarwin ''
- export OBJC_DISABLE_INITIALIZE_FORK_SAFETY=YES
- '' + ''
- mkdir -p src/nix-channel
- make installcheck -j$NIX_BUILD_CORES -l$NIX_BUILD_CORES
- '';
- });
-
binaryTarball = nix: pkgs:
let
inherit (pkgs) buildPackages;
@@ -147,10 +114,6 @@
overlayFor = getStdenv: final: prev:
let
currentStdenv = getStdenv final;
- comDeps = with final; commonDeps {
- inherit pkgs;
- inherit (currentStdenv.hostPlatform) isStatic;
- };
in {
nixStable = prev.nix;