diff options
author | Maximilian Bosch <maximilian@mbosch.me> | 2024-09-25 18:31:34 +0200 |
---|---|---|
committer | Maximilian Bosch <maximilian@mbosch.me> | 2024-09-25 18:31:34 +0200 |
commit | eccbe9586a12316252e64ee3db3a453fc19777e4 (patch) | |
tree | b96206ba8a9bc649c35f5e190d6edd3863028149 /flake.nix | |
parent | 5f298f74c92402a8390b01c736463b17b36277e3 (diff) |
flake: use clangStdenv for `overlays.default`
We don't support GCC anymore for building, so the overlay currently
fails to evaluate with
error: assertion '((stdenv).cc.isClang || lintInsteadOfBuild)' failed
`clangStdenv` seems like a reasonable default now.
Noticed while upgrading Lix for our Hydra fork.
Change-Id: I948a7c03b3e5648fc7c596f96e1b8053a9e7f92f
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -217,7 +217,7 @@ # A Nixpkgs overlay that overrides the 'nix' and # 'nix.perl-bindings' packages. - overlays.default = overlayFor (p: p.stdenv); + overlays.default = overlayFor (p: p.clangStdenv); hydraJobs = { # Binary package for various platforms. |