aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2022-11-27 16:38:34 +0100
committerEelco Dolstra <edolstra@gmail.com>2022-11-27 16:38:34 +0100
commitf1b5c6876bc570ff9ac79410d8e47aadcb9aed52 (patch)
treeb6553ae70afaab23b51d02952353823748e8903b /flake.nix
parent2aa3f2e81020c1c780be6329e1133068779c8f08 (diff)
Add tests for auto-uid-allocation, uid-range and cgroups
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index cc2a48d9c..d9d01da10 100644
--- a/flake.nix
+++ b/flake.nix
@@ -506,6 +506,12 @@
overlay = self.overlays.default;
});
+ tests.containers = (import ./tests/containers.nix rec {
+ system = "x86_64-linux";
+ inherit nixpkgs;
+ overlay = self.overlays.default;
+ });
+
tests.setuid = nixpkgs.lib.genAttrs
["i686-linux" "x86_64-linux"]
(system: