aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorYorick van Pelt <yorick@yorickvanpelt.nl>2022-11-25 14:47:05 +0100
committerAlexander Bantyev <balsoft@balsoft.ru>2023-02-13 12:00:00 +0400
commitf2e427942dbdef460c6ba5641a571388f692bff9 (patch)
tree0427ef035cfcb270b1f84e754be04f804367b6ae /flake.nix
parent012ddaa3228cbf0bd99309cbfb2ad46feb7bf27e (diff)
Improve hacking.md
- Refer to current version in readme - Split into flakes and non-flakes section - Change order to move nix-build to the end, since people often start with it in the beginning. - Use proper "Note" syntax - Add notes about editor integration - Move information about target platforms and stdenvs into separate sections Co-authored-by: Valentin Gagarin <valentin.gagarin@tweag.io> Co-authored-by: Alexander Bantyev <alexander.bantyev@tweag.io> Co-authored-by: Théophane Hufschmitt <theophane.hufschmitt@tweag.io>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index f3a401868..1707c53b8 100644
--- a/flake.nix
+++ b/flake.nix
@@ -701,7 +701,10 @@
outputs = [ "out" "dev" "doc" ];
- nativeBuildInputs = nativeBuildDeps ++ [ clang-tools bear ];
+ nativeBuildInputs = nativeBuildDeps
+ ++ (lib.optionals
+ nixpkgsFor.${system}.${stdenv}.cc.isClang
+ [ bear clang-tools ]);
buildInputs = buildDeps ++ propagatedDeps ++ awsDeps;
inherit configureFlags;