aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-06-26 00:44:46 -0700
committerJade Lovelace <lix@jade.fyi>2024-06-26 00:44:46 -0700
commitf7d54cb6b106fc24673f62c9dce050615d71eb1d (patch)
tree82801e6a7a93810d78dca1195f3a68e51a248391 /flake.nix
parent4ac2c496d499a4a0e2d64edf32eb855268e7aa8d (diff)
packaging: make pegtl use the __forDefaults mechanism
This avoids needing to pass it in when callPackage'ing Lix from external code. Change-Id: Ie07e84a151e38614064609a2f6dbff165e193be7
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index c3707c919..2b5f112a4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -195,16 +195,19 @@
busybox-sandbox-shell = final.busybox-sandbox-shell or final.default-busybox-sandbox-shell;
};
- pegtl = final.callPackage ./misc/pegtl.nix { };
+ pegtl = final.nix.passthru.pegtl;
# Export the patched version of boehmgc that Lix uses into the overlay
# for consumers of this flake.
- boehmgc-nix = final.nix.boehmgc-nix;
+ boehmgc-nix = final.nix.passthru.boehmgc-nix;
# And same thing for our build-release-notes package.
- build-release-notes = final.nix.build-release-notes;
+ build-release-notes = final.nix.passthru.build-release-notes;
};
in
{
+ # for repl debugging
+ inherit self;
+
# A Nixpkgs overlay that overrides the 'nix' and
# 'nix.perl-bindings' packages.
overlays.default = overlayFor (p: p.stdenv);