aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2022-09-14 15:40:43 +0200
committerEelco Dolstra <edolstra@gmail.com>2022-09-14 15:41:11 +0200
commitfae3b4fe8abc2b307a583e396a24d7899bb21451 (patch)
tree0c0ca0e2d7a4a588b12e465c2bf45c5590bc1e75 /flake.nix
parentb8f334bd8520d6fc9eb33258cc75d4acb57554b1 (diff)
Add an installer test
This runs the installer in a QEMU VM. Unlike the old installer test that ran inside a declaratively built RedHat/Debian image, this uses an image from Vagrant.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index cdb81179a..ec64719d1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -546,6 +546,11 @@
# againstLatestStable = testNixVersions pkgs pkgs.nix pkgs.nixStable;
} "touch $out");
+ installerTests = import ./tests/installer {
+ binaryTarballs = self.hydraJobs.binaryTarball;
+ inherit nixpkgsFor;
+ };
+
};
checks = forAllSystems (system: {