aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-04-18 16:15:24 -0600
committerQyriad <qyriad@qyriad.me>2024-04-18 16:15:58 -0600
commit111db8b38fd8350d92d72fa17fd3d9e8ef5a0e09 (patch)
tree93d0687870293ef4c59bc327c2bd2057c7ceebc5 /meson.build
parenta326344253ee55d50476ff696b83ffb15366852d (diff)
meson: correctly embed sandbox shell when asked
Change-Id: I2f6c0d42245204a516d2e424eea26a6391e975ad
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0c0bfb8f0..2128ec6e2 100644
--- a/meson.build
+++ b/meson.build
@@ -284,6 +284,16 @@ endif
# Used to workaround https://github.com/mesonbuild/meson/issues/2320 in src/nix/meson.build.
installcmd = find_program('install')
+enable_embedded_sandbox_shell = get_option('enable-embedded-sandbox-shell')
+if enable_embedded_sandbox_shell
+ # This one goes in config.h
+ # The path to busybox is passed as a -D flag when compiling libstore.
+ # Idk why, ask the old buildsystem.
+ configdata += {
+ 'HAVE_EMBEDDED_SANDBOX_SHELL': 1,
+ }
+endif
+
sandbox_shell = get_option('sandbox-shell')
# Consider it required if we're on Linux and the user explicitly specified a non-default value.
sandbox_shell_required = sandbox_shell != 'busybox' and host_machine.system() == 'linux'