aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPierre Bourdon <delroth@gmail.com>2024-06-08 16:57:08 +0200
committerPierre Bourdon <delroth@gmail.com>2024-06-09 01:25:53 +0200
commit28a079f841834ac11105ce5762115904d1e40ce1 (patch)
tree4e822c57bce9c259d5728cc8cc8abd3c46fe591d /meson.build
parent9281a12532165054e208072e53d1b07501fe7526 (diff)
flake: update nixpkgs pin 23.11->24.05 (+ boehmgc compat changes)
The boehmgc changes are bundled into this commit because doing otherwise would require an annoying dance of "adding compatibility for < 8.2.6 and >= 8.2.6" then updating the pin then removing the (now unneeded) compatibility. It doesn't seem worth the trouble to me given the low complexity of said changes. Rebased coroutine-sp-fallback.diff patch taken from https://github.com/NixOS/nixpkgs/pull/317227 Change-Id: I8c590e9fe25c0f566d0cfeacb96d8cf50abf12e8
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4a42b7a73..e5fb21e88 100644
--- a/meson.build
+++ b/meson.build
@@ -189,7 +189,7 @@ configdata = { }
# Dependencies
#
-boehm = dependency('bdw-gc', required : get_option('gc'))
+boehm = dependency('bdw-gc', required : get_option('gc'), version : '>=8.2.6')
if boehm.found()
deps += boehm
endif