aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOlivia Crain <olivia@olivia.dev>2024-09-24 17:23:53 -0500
committerOlivia Crain <olivia@olivia.dev>2024-09-27 12:26:07 -0500
commit4780dd6bc4f33a5340934ac3ff1c47ee682ca395 (patch)
tree6f11a550f5a245d7fd8e0842615f32f6732a14af /meson.build
parentb86863d93565a05b7695e3579caa2fe2ab62f3a1 (diff)
build: let meson add compiler flags for libstdc++ assertions
We have manually enabled libstdc++ assertions since cl/797. Meson 1.4.0 (the minimum version we mandate) enables this by default, so we can remove the enabling compiler flag from the list of project arguments. With this patch, `-D_GLIBCXX_ASSERTIONS=1` is still present in the compile command logs when building with both gccStdenv and clangStdenv. See: https://gerrit.lix.systems/c/lix/+/797 See: https://mesonbuild.com/Release-notes-for-1-4-0.html#ndebug-setting-now-controls-c-stdlib-assertions Change-Id: I53483fadfe5cbd11ba35544b437d3a9ee8031631
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 0 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index ea2050b6b..a8c6b9621 100644
--- a/meson.build
+++ b/meson.build
@@ -493,12 +493,6 @@ add_project_arguments(
'-Wdeprecated-copy',
'-Wignored-qualifiers',
'-Werror=suggest-override',
- # Enable assertions in libstdc++ by default. Harmless on libc++. Benchmarked
- # at ~1% overhead in `nix search`.
- #
- # FIXME: remove when we get meson 1.4.0 which will default this to on for us:
- # https://mesonbuild.com/Release-notes-for-1-4-0.html#ndebug-setting-now-controls-c-stdlib-assertions
- '-D_GLIBCXX_ASSERTIONS=1',
language : 'cpp',
)