aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorjade <lix@jade.fyi>2024-06-07 03:53:31 +0000
committerGerrit Code Review <gerrit@lix-systems>2024-06-07 03:53:31 +0000
commit4f94531209510c7d580e525a017ea01f18894ded (patch)
treec5b8e06f73a5fd27ed6afa53a22b9fca145c4638 /meson.build
parentec768df0046659e75974919f5923661a29ff52c9 (diff)
parent611b1de441a54d3ed7781ca0a26b51b6cb9c45cc (diff)
Merge changes from topic "releng" into main
* changes: Add meson release note Move version to a JSON file so we can have release names Remove rl-next-dev
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7fd29bdf5..4a42b7a73 100644
--- a/meson.build
+++ b/meson.build
@@ -39,7 +39,7 @@
# in the build directory.
project('lix', 'cpp',
- version : run_command('bash', '-c', 'echo -n $(cat ./.version)$VERSION_SUFFIX', check : true).stdout().strip(),
+ version : run_command('bash', '-c', 'echo -n $(jq -r .version < ./version.json)$VERSION_SUFFIX', check : true).stdout().strip(),
default_options : [
'cpp_std=c++2a',
# TODO(Qyriad): increase the warning level