aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-29 02:37:14 +0100
committereldritch horrors <pennae@lix.systems>2024-03-29 02:45:48 +0000
commit6e5db5e4a226dc920a8959e8201d75f54c37dde2 (patch)
tree31670ff7dd821d154eabf0a833a3c28d6be1cb41 /meson.build
parent69bfd21e20cfd136af99f98dea26b5c0b5d934d3 (diff)
meson: install missing/generated headers
one headers (args/root.hh) was simply missing, and the generated headers were not installed. not all of them *should* be installed either, only a select few (and sadly this needs a custom target for each one, it seems) Change-Id: I37b25517895d0e5e521abc1202fa65624de57ed1
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 556712c34..a4c2bbc14 100644
--- a/meson.build
+++ b/meson.build
@@ -244,13 +244,12 @@ bison = find_program('bison')
flex = find_program('flex')
# This is how Nix does generated headers...
+# other instances of header generation use a very similar command.
# FIXME(Qyriad): do we really need to use the shell for this?
+gen_header_sh = 'echo \'R"__NIX_STR(\' | cat - @INPUT@ && echo \')__NIX_STR"\''
gen_header = generator(
bash,
- arguments : [
- '-c',
- 'echo \'R"__NIX_STR(\' | cat - @INPUT@ && echo \')__NIX_STR"\'',
- ],
+ arguments : [ '-c', gen_header_sh ],
capture : true,
output : '@PLAINNAME@.gen.hh',
)