aboutsummaryrefslogtreecommitdiff
path: root/misc/changelog-d.cabal.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-26 18:32:25 +0100
committereldritch horrors <pennae@lix.systems>2024-03-27 03:09:14 +0000
commit279e30e7ef4cae96d1f5fcbc5fc02ebb4779199b (patch)
tree045935b89a5067c297cb50e7a28ca3a81cf411fc /misc/changelog-d.cabal.nix
parent8fd02df90d2a8099d2d547e151b876f77fb5a4a2 (diff)
build: replace changelog-d with local script
hacking changelog-d to support not just github but also forgejo and gerrit is a lot more complicated than it's worth, even moreso since the entire thing can just as well be done with ~60 lines of python. this new script is also much cheaper to instantiate (being python), so having it enabled in all shells is far less of a hassle. we've also adjusted existing release notes that referenced a gerrit cl to auto-link to the cl in question, making the diff a bit bigger closes https://git.lix.systems/lix-project/lix/issues/176 Change-Id: I8ba7dd0070aad9ba4474401731215fcf5d9d2130
Diffstat (limited to 'misc/changelog-d.cabal.nix')
-rw-r--r--misc/changelog-d.cabal.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/misc/changelog-d.cabal.nix b/misc/changelog-d.cabal.nix
deleted file mode 100644
index 76f9353cd..000000000
--- a/misc/changelog-d.cabal.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ mkDerivation, aeson, base, bytestring, cabal-install-parsers
-, Cabal-syntax, containers, directory, filepath, frontmatter
-, generic-lens-lite, lib, mtl, optparse-applicative, parsec, pretty
-, regex-applicative, text, pkgs
-}:
-let rev = "f30f6969e9cd8b56242309639d58acea21c99d06";
-in
-mkDerivation {
- pname = "changelog-d";
- version = "0.1";
- src = pkgs.fetchurl {
- name = "changelog-d-${rev}.tar.gz";
- url = "https://codeberg.org/roberth/changelog-d/archive/${rev}.tar.gz";
- hash = "sha256-8a2+i5u7YoszAgd5OIEW0eYUcP8yfhtoOIhLJkylYJ4=";
- } // { inherit rev; };
- isLibrary = false;
- isExecutable = true;
- libraryHaskellDepends = [
- aeson base bytestring cabal-install-parsers Cabal-syntax containers
- directory filepath frontmatter generic-lens-lite mtl parsec pretty
- regex-applicative text
- ];
- executableHaskellDepends = [
- base bytestring Cabal-syntax directory filepath
- optparse-applicative
- ];
- doHaddock = false;
- description = "Concatenate changelog entries into a single one";
- license = lib.licenses.gpl3Plus;
- mainProgram = "changelog-d";
-}