aboutsummaryrefslogtreecommitdiff
path: root/misc/meson.build
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-08-09 23:24:17 -0700
committerJade Lovelace <lix@jade.fyi>2024-08-10 16:10:16 -0700
commit0c7619535112e19232384e15e82ffa6a5af7569d (patch)
treec9500d6bc74b50a8bb39f580ebf5389de10e786c /misc/meson.build
parent292567e0b0a4681eb8ca803c26293d70857fe387 (diff)
build: remove expect as a dependency
I was packaging Lix 2.91 for nixpkgs and was annoyed at the expect dependency. Turns out that you can replace unbuffer with a pretty-short Python script. It became less short after I found out that Linux was converting \n to \r\n in the terminal subsystem, which was not very funny, but is at least solved by twiddling termios bits. Change-Id: I8a2700abcbbf6a9902e01b05b40fa9340c0ab90c
Diffstat (limited to 'misc/meson.build')
-rw-r--r--misc/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/misc/meson.build b/misc/meson.build
index a8f09722c..bf3c157f7 100644
--- a/misc/meson.build
+++ b/misc/meson.build
@@ -4,3 +4,9 @@ subdir('zsh')
subdir('systemd')
subdir('flake-registry')
+
+runinpty = configure_file(
+ copy : true,
+ input : meson.current_source_dir() / 'runinpty.py',
+ output : 'runinpty.py',
+)