aboutsummaryrefslogtreecommitdiff
path: root/misc/zsh/meson.build
diff options
context:
space:
mode:
authorOlivia Crain <olivia@olivia.dev>2024-09-26 14:28:25 -0500
committerOlivia Crain <olivia@olivia.dev>2024-09-27 11:55:32 -0500
commit624f44bf25902beaf5599bf031ef3610820b1f6a (patch)
tree2273102c5ab68d877f1dd067059858354dfe7b42 /misc/zsh/meson.build
parent0e6b3435a14a304b8833c27d2911de7ac4e731d4 (diff)
build: fix deprecated uses of configure_file
Using `configure_file` to copy files has been deprecated since Meson 0.64.0. The intended replacement is the `fs.copyfile` method. This removes the following deprecation warning that arises when a minimum Meson version is specified: `` Project [...] uses feature deprecated since '0.64.0': copy arg in configure_file. Use fs.copyfile instead `` Change-Id: I09ffc92e96311ef9ed594343a0a16d51e74b114a
Diffstat (limited to 'misc/zsh/meson.build')
-rw-r--r--misc/zsh/meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/misc/zsh/meson.build b/misc/zsh/meson.build
index 8063a5cb8..bd388a31f 100644
--- a/misc/zsh/meson.build
+++ b/misc/zsh/meson.build
@@ -1,10 +1,9 @@
foreach script : [ [ 'completion.zsh', '_nix' ], [ 'run-help-nix' ] ]
- configure_file(
- input : script[0],
- output : script.get(1, script[0]),
+ fs.copyfile(
+ script[0],
+ script.get(1, script[0]),
install : true,
install_dir : datadir / 'zsh/site-functions',
install_mode : 'rw-r--r--',
- copy : true,
)
endforeach